通达信公式网 通达信公式网收录通达信公式、大智慧公式、飞狐公式等.域名jiachenglong.cn(谐音"假成龙")

loadding...

分析家鳄鱼线源码解析

发布时间: 2016-10-13 13:56

   分析家鳄鱼线源码解析 


分析家鳄鱼线源码解析

 

    Y:=(H+L)/2;


    BLUE:=SMA(Y,13,1);


    RED:=SMA(Y,8,1);


    GREEN:=SMA(Y,5,1);


    B2:=REF(BLUE,8);


    R2:=REF(RED,5);


    G2:=REF(GREEN,3);


    KU1:=IF(H=HHV(H,3),1,0);


    KD1:=IF(L=LLV(L,3),1,0);


    UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0,REF(H,2),REF(H,2+BARSLAST(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0)));


    DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(L,2),REF(L,2+BARSLAST(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0)));


    KU:=IF(C>B2 AND C>R2 AND C>G2,1,0);


    KD:=IF(C<B2 AND C<R2 AND C<G2,-1,0);


    KK:=IF(BARSLAST(KU=1 AND REF(KU,1)=0)<BARSLAST(KD=-1 AND REF(KD,1)=0),1,-1);


    AO:=MA(Y ,5 )-MA(Y ,34 );


    AC:=AO-MA( AO,5);


    ac1:=ref(AC,1);


    ao1:=ref(ao,1);


    AOz170*MA(Y,5)-170*MA(Y,34)+165*MA(Y,33)-136*MA(Y,4))/29,linethick0;


    AOl165*ma(Y,33)-136*ma(Y,4))/29,linethick0;


    ACz5*34*5*AO-5*34*5*MA(AO,5)+5*34*4*MA(AO,4)+5*4*33*MA(Y,33)-4*34*4*MA(Y,4))/116,linethick0;


    ACl5*34*MA(AO,4)-34*4*MA(Y,4)+5*33*MA(Y,33))/29,linethick0;


    KAC:=IF(AC>ac1 AND Ao>ao1,1,0);


    KAO:=IF(AC<ac1 AND Ao<ao1,-1,0);


    蓝:SMA(Y,13,1),COLORBLUE;


    红:SMA(Y,8,1),COLORRED;


    绿:SMA(Y,5,1),COLORGREEN;


    上碎型:IF(H>=R2,UL,REF(UL,BARSLAST(H>R2))),COLORMAGENTA,linethick0;


    下碎型:IF(L<=R2,DL,REF(DL,BARSLAST(L<=R2))),COLORYELLOW,linethick0;


    STICKLINE(BARSLAST(ABS(上碎型-REF(上碎型,1)))上碎型 AND REF(c,1)<REF(上碎型,1)),上碎型,上碎型,3,1),COLORMAGENTA;


    STICKLINE(BARSLAST(ABS(下碎型-REF(下碎型,1)))<BARSLAST(c<下碎型 and="">REF(下碎型,1)),下碎型,下碎型,3,1),COLORYELLOW;


    OL:=(170*MA(Y,5)-170*MA(Y,34)+165*MA(Y,33)-136*MA(Y,4))/29;


    CL:=(165*ma(y,33)-136*ma(y,4)+170*(4*MA(AO,4)+5*(REF(AO,4)-MA(REF(AO,4),5)))/4)/29;


    H1:=REF(H,4);


    H2:=REF(H,3);


    H3:=REF(H,2);


    H4:=REF(H,1);


    H5:=H;


    L1:=REF(L,4);


    L2:=REF(L,3);


    L3:=REF(L,2);


    L4:=REF(L,1);


    L5:=L;


    DRAWICON(c>上碎型 AND REF(c,1)<REF(上碎型,1),H*1.015,4);


    DRAWICON(c<下碎型 and="">REF(下碎型,1),L*0.99,5);


    DRAWICON(KU=1 AND REF(KU,1)=0 and c<0,L,4);


    DRAWICON(KD=-1 AND REF(KD,1)=0 and c<0,H*1.01,5);


    DRAWICON(KU=0 AND REF(KU,1)=1 and c<0,H*1.01,7);


    DRAWICON(KD=0 AND REF(KD,1)=-1 and c<0,L,6);


    STICKLINE(KAC=1 AND C>=O,O,C,8,1),COLORRED;


    STICKLINE(KAO=-1 AND C>=O,O,C,8,1),COLORGREEN;


    STICKLINE(KAO=0 AND KAC=0 AND C>=O,O,C,8,1),COLORGRAY;


    STICKLINE(C>=O,H,C,0.4,1),COLORRED;


    STICKLINE(C>=O,O,L,0.4,1),COLORRED;


    STICKLINE(KAC=1 AND C<O,O,C,8,0),COLORRED;


    STICKLINE(KAO=-1 AND C<O,O,C,8,0),COLORGREEN;


    STICKLINE(KAO=0 AND KAC=0 AND C<O,O,C,8,0),COLORGRAY;


    STICKLINE(O>C,H,O,0.4,1),COLORCYAN;


    STICKLINE(O>C,C,L,0.4,1),COLORCYAN;


    DU0:=CROSS(AO,0);


    UD0:=CROSS(0,AO);


    TDU0:=BARSLAST(DU0);


    TUD0:=BARSLAST(UD0);


    DU3:=REF(DU0,1);


    UD3:=REF(UD0,1);


    TDU3:=BARSLAST(DU3);


    TUD3:=BARSLAST(UD3);


    UDGLINE:=IF(TDU3<TUD3,REF(HHV(H,2),TDU3),REF(LLV(L,2),TUD3));


    JDU0:=REF(C,1)<=ref(udgline,1) and="" c="">UDGLINE AND TDU0<TUD0;


    JUD0:=REF(C,1)>=REF(UDGLINE,1) AND C<UDGLINE AND TUD0<TDU0;


    JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;


    JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;


    JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);


    JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);


    JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);


    JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);


    DRAWTEXT(JDU2,L*0.9,'<=空转多');


    DRAWTEXT(JUD2,H*1.2,'<=多转空');


    DRAWTEXT(JDU3,L*0.9,'<=多续多');


    DRAWTEXT(JUD3,H*1.2,'<=空续空');


    yy:=(h+l+c)/3;


    均价:STICKLINE(yy>0.05,yy,yy,9,0),COLORBLUE;{当天成交重心};


    VA:=CROSS(EMA(c,3),EMA(C,13));


    VB:=EMA(C,3)>EMA(C,8);


    DRAWICON(VA and  VB,EMA(c,8),1);


    VarA:=IF(CLOSE and MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,88,0);


    VarB:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 and="" vara="">0, 91, 0);


    STICKLINE(VarB>90,L*0.99,L*0.98,5,0),COLORYELLOW;


    DRAWTEXT(VarB>90,LOW*0.98,'▲追涨'),COLORYELLOW;


    V1:=EMA(EMA(EMA(CLOSE,8),13),55);


    V2:=(REF(HIGH,1)+REF(LOW,1))/2;


    V3:=MA(CLOSE,20)+2*STD(CLOSE,20);


    DRAWICON(CROSS(V2,V3),HIGH*1.035,2);


    DRAWTEXT(CROSS(V2,V3),HIGH*1.02,'<--卖出'),COLORblue;


    V4:=REF(CLOSE,1);


    V5:=SMA(MAX(CLOSE-V4,0),7,1)/SMA(ABS(CLOSE-V4),7,1)*100;


    V6:=CROSS(79,V5);


    V7:=FILTER(V6,4);


    DRAWICON(V7,HIGH*1.035,2);


    DRAWTEXT(V7,HIGH*1.02,'<--卖出'),COLORgreen;

 

关于本站 | 法律声明 | 广告合作 | RSS订阅

备案号 琼ICP备13000527号-1 同花顺公式 | 通达信公式 | 通达信指标公式

jiachenglong.cn .All Rights Reserved 联系QQ:3309881897.