通达信公式网 通达信公式网收录通达信公式、大智慧公式、飞狐公式等.域名jiachenglong.cn(谐音"假成龙")

loadding...

同花顺公式_财神布林_源码

发布时间: 2016-12-15 20:24

  同花顺公式_财神布林_源码


  N:=10;P:=3;

  BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

  UPR:BBI+P*STD(BBI,N);

  DWN:BBI-P*STD(BBI,N);

  DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ;

  DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);

  VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

  VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

  VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

  VAR6:=(VAR3+VAR4+VAR5)/3;

  VAR7:=EMA(VAR6,5);

  ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;

  VAR8:=IF(VAR6<=-20,10,0);

  VAR9:=HHV(VAR8,10);

  VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);

  K:=EMA(VAR7,5)*2, , COLORFF00FF;

  D:=EMA(K,5), , colorwhite;

  J:=K*3-D*2, ,coloryellow;

  VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;

  HS:=VOL/CAPITAL*100, , colorgreen;

  DRAWTEXT(VAR8=10 AND FILTER(VAR8=10,5),LOW*0.93,'接近底部'); colormagenta;

  DRAWTEXT(VARA=20,LOW*0.95,'底部'); coloryellow;

  VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

  VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

  DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'大资金活动'),LINETHICK1,COLORFF00FF;

  VAR12:=(HIGH+LOW+CLOSE)/3;

  VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

  VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

  VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

  VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);

  VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

  VAR18:=100-ABS(VAR17);

  VAR19:=IF(VAR18<90,VAR18,100);

  VAR1A:=IF(VARE>0,VARE,0);

  VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

  VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;

  DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'大笔成交'); colorwhite;


同花顺公式_财神布林_源码

 

关于本站 | 法律声明 | 广告合作 | RSS订阅

备案号 琼ICP备13000527号-1 同花顺公式 | 通达信公式 | 通达信指标公式

jiachenglong.cn .All Rights Reserved 联系QQ:3309881897.