通达信公式网 通达信公式网收录通达信公式、大智慧公式、飞狐公式等.域名jiachenglong.cn(谐音"假成龙")

loadding...

同花顺公式_太极波段交易线_源码

发布时间: 2016-12-15 20:37

  同花顺公式_太极波段交易线_源码


  MA5:MA(C,3);

  MA6:MA(C,5);

  MA10:MA(C,6);

  MA20:MA(C,18);

  A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);

  MA30:MA(C,30);

  MA55:MA(C,60);

  MA120:MA(C,120);

  VAR3:=LLV(HIGH,240);

  VAR4:=100*(CLOSE-VAR3);

  VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

  VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

  VAR7:=0;

  VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

  VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

  VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

  VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

  VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

  VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

  VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

  VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

  VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

  VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

  VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

  VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);

  买1:=VAR10;

  买2:=(VAR11+VAR13+VAR15+VAR17);

  卖1:=(VAR12+VAR14+VAR16+VAR18);

  B:IF(买1>0 OR 买2>0,LOW*0.985,DRAWNULL),coloryellow;

  DRAWTEXT(买1>0 OR 买2>0,LOW*0.980,'粮食'),colorlired;

  S:IF(卖1>0,HIGH*1.005,DRAWNULL),coloryellow;

  DRAWTEXT(卖1>0,HIGH*1.018,'空仓'),LINETHICK5,colorligreen;

  DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.985,1) ;

  DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.005,2);

  ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;

  VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);

  K:=EMA(VAR7,5)*2, , COLORFF00FF;

  D:=EMA(K,5), , colorwhite;

  J:=K*3-D*2, ,coloryellow;

  VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;

  HS:=VOL/CAPITAL*100, , colorgreen;

  VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

  VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.975,'鬼子进村'),LINETHICK5,colorlimagenta;

  VAR1A:=IF(VARE>0,VARE,0);

  VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

  VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;

  DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*1.05,'解放军站岗'),LINETHICK5, colorwhite;

  A:=(3*C+L+O+H)/6;

  X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;

  S2:=SMA(C,3,1);//www.88gs.com

  S6:=SMA(C,5,1);

  DK:=2*(S2-S6);

  主力成本:EMA(X,13),LINETHICK2,colorbrown;

  AA:=ZIG(3,7);

  BB:=MA(AA,2);

  DRAWICON(CROSS(AA,BB),L*1.0 ,"BUY");

  DRAWICON(CROSS(BB,AA),H *1.0,"SELL");

  STICKLINE(AA<BB,AA,BB,10,0);LINETHICK5,colorgreen;

  STICKLINE(AA>BB,AA,BB,10,0);LINETHICK5,colorred;

  STICKLINE(MA5<=MA10,MA5,MA10,10,0);LINETHICK6,colorgreen;

  STICKLINE(MA5>=MA10,MA5,MA10,10,0);LINETHICK6,colorlired;

 

关于本站 | 法律声明 | 广告合作 | RSS订阅

备案号 琼ICP备13000527号-1 同花顺公式 | 通达信公式 | 通达信指标公式

Copyright © 湖南携景网络技术有限公司 jiachenglong.cn .All Rights Reserved .