通达信公式网 通达信公式网收录通达信公式、大智慧公式、飞狐公式等.域名jiachenglong.cn(谐音"假成龙")

loadding...

浮华——超级MACD_源码

发布时间: 2016-12-15 20:42

  浮华——超级MACD_源码


  DIFF:EMA(CLOSE,9)-EMA(CLOSE,17);

  DEA:EMA(DIFF,8),COLOrffaa00;

  MACD:=2*(DIFF-DEA);

  STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;

  STICKLINE(MACD<0,MACD,0,4,1),colorwhite;

  STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,4,0 ),COLOR00aaff;

  X1:IF(diff<0,diff,0),COLOR0000FF,LINETHICK2;

  X2:IF(diff<0,0,diff),colormagenta,LINETHICK1;

  X3:IF(diff<dea,diff,dea),COLOR00ff00,linethick1;

  X4:IF(diff>dea,dea,dea),linethick1,COLORffbb11;

  低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

  STICKLINE(低位金叉,DEA*0.86,DEA*0.66,6,0),coloryellow;

  DRAWTEXT(低位金叉,dea*0.86,' 低位金叉'),coloryellow;

  JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

  二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

  STICKLINE(二次金叉,DEA*0.96,DEA*0.76,6,0),ColorFF00FF;

  DRAWICON(二次金叉,dea*1.1,'BUY') ;

  DRAWTEXT(二次金叉,DEA*0.96,' 二次金叉'),ColorFF00FF;

  A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

  底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

  STICKLINE(底背离,DEA*1.09,DEA*0.86,6,0),Color00FF00;

  DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,linethick1;

  DRAWTEXT(底背离,DEA*1.09,' 底背离'),Color6600FF;

  A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));//www.88gs.com

  顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

  DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,linethick1;

  DRAWTEXT(顶背离,DEA*1.2,' 顶背离'),Color00FF00;

  DRAWTEXT_FIX(1,0.01,0.82,0,


浮华——超级MACD_源码

 

关于本站 | 法律声明 | 广告合作 | RSS订阅

备案号 琼ICP备13000527号-1 同花顺公式 | 通达信公式 | 通达信指标公式

Copyright © 湖南携景网络技术有限公司 jiachenglong.cn .All Rights Reserved .