通达信公式网 通达信公式网收录通达信公式、大智慧公式、飞狐公式等.域名jiachenglong.cn(谐音"假成龙")

loadding...

通达信公式_熊市捉妖副图_源码

发布时间: 2016-12-20 23:09

    通达信公式_熊市捉妖副图_源码


   公式源码:

    A7A:=CLOSE-REF(CLOSE,1);

    A8A:=100*EMA(EMA(A7A,6),6)/EMA(EMA(ABS(A7A),6),6);

    出关线:=(-50);

    XG1:=CROSS(A8A,出关线);

    PER1:=5;

    MMA:=EMA(CLOSE,PER1);

    SMMA:=EMA(MMA,PER1);

    IMPETMMA:=MMA-REF(MMA,1);

    IMPETSMMA:=SMMA-REF(SMMA,1);

    DIVMA:=ABS(MMA-SMMA);

    AVERIMPET:=(IMPETMMA+IMPETSMMA)/2;

    TDF:=POW(DIVMA,1)*POW(AVERIMPET,3);

    NTDF:=TDF/HHV(ABS(TDF),PER1*3);

    A:=(-0.05);

    B:=0.05;

    XG2:=CROSS(NTDF,(-0.6));

    VAR4:=EMA(CLOSE,3);

    VAR5:=LLV(HIGH,240);

    VAR6:=100*(CLOSE-VAR5)/VAR5;

    VARF:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;

    XG1A:=COUNT(REF(VAR4,1)<REF(VAR4,2),5)=5 AND VAR4>REF(VAR4,1);

    XG2A:=FILTER(COUNT(VAR6<0,5) AND CROSS(VAR6,0) AND VARF>REF(VARF,1) AND CLOSE>OPEN,3);

    XG3A:=XG1A OR XG2A;

    AA:=REF(CLOSE,1);

    BBB:=SMA(MAX(CLOSE-AA,0),34,1)/SMA(ABS(CLOSE-AA),34,1)*1000;

    HHH:=BBB-LLV(BBB,36);

    短期:=(MA(HHH,2)*3+HHH*13)/16;

    中期:=MA(HHH,10);

    CCC:=LLV(BBB,36)-BBB;

    短期二:=(MA(CCC,2)*3+CCC*13)/16;

    中期二:=MA(CCC,10);

    XG4A:=CROSS(短期,中期) AND CROSS(中期二,短期二);

    XG3:=XG3A AND XG4A;

    PRD1:=5;

    STEP:=(SQRT(5)-1)/2;

    A1:=IF(CLOSE>MA(CLOSE,PRD1),10,IF(CLOSE<MA(CLOSE,PRD1),(-10),0));

    A2:=IF(CLOSE>MA(CLOSE,PRD1/STEP),10,IF(CLOSE<MA(CLOSE,PRD1/STEP),(-10),0));

    A3:=IF(CLOSE>MA(CLOSE,INTPART(PRD1/POW(STEP,2))),10,IF(CLOSE<MA(CLOSE,INTPART(PRD1/POW(STEP,2))),(-10),0));

    A4:=IF(CLOSE>MA(CLOSE,INTPART(PRD1/POW(STEP,3))),10,IF(CLOSE<MA(CLOSE,INTPART(PRD1/POW(STEP,3))),(-10),0));

    A5:=IF(CLOSE>MA(CLOSE,INTPART(PRD1/POW(STEP,4))),10,IF(CLOSE<MA(CLOSE,INTPART(PRD1/POW(STEP,4))),(-10),0));

    A6:=IF(CLOSE>MA(CLOSE,INTPART(PRD1/POW(STEP,5))),10,IF(CLOSE<MA(CLOSE,INTPART(PRD1/POW(STEP,5))),(-10),0));

    A7:=IF(CLOSE>MA(CLOSE,INTPART(PRD1/POW(STEP,6))),10,IF(CLOSE<MA(CLOSE,INTPART(PRD1/POW(STEP,6))),(-10),0));

    A8:=IF(CLOSE>MA(CLOSE,INTPART(PRD1/POW(STEP,7))-1),10,IF(CLOSE<MA(CLOSE,INTPART(PRD1/POW(STEP,7))-1),(-10),0));

    A9:=IF(CLOSE>MA(CLOSE,INTPART(PRD1/POW(STEP,8))-1),10,IF(CLOSE<MA(CLOSE,INTPART(PRD1/POW(STEP,8))-1),(-10),0));

    A10:=IF(CLOSE>MA(CLOSE,INTPART(PRD1/POW(STEP,9))-3),10,IF(CLOSE<MA(CLOSE,INTPART(PRD1/POW(STEP,9))-3),(-10),0));

    XGB:=A1+A2+A3+A4+A5+A6+A7+A8+A9+A10;

    XG4:=CROSS(XGB,(-99));

    K:=(CLOSE+HIGH+LOW)/3;

    D:=MA(K,4);

    XG1C:=REF(CLOSE,1)<D AND CLOSE>D AND D<REF(D,1);

    VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*50;

    AAC:=EMA(VAR1,3)*2;

    XG2C:=CROSS(AAC,20);

    XG5:=XG2C AND XG1C;

    TDXSTEP494:XG1 AND XG2 AND XG3 AND XG4 AND XG5,COLORRED,LINETHICK2;


通达信公式_熊市捉妖副图_源码

 

关于本站 | 法律声明 | 广告合作 | RSS订阅

备案号 琼ICP备13000527号-1 同花顺公式 | 通达信公式 | 通达信指标公式

jiachenglong.cn .All Rights Reserved 联系QQ:3309881897.