通达信公式网 通达信公式网收录通达信公式、大智慧公式、飞狐公式等.域名jiachenglong.cn(谐音"假成龙")

loadding...

通达信公式_简单BS主图_源码

发布时间: 2016-12-20 23:11

    通达信公式_简单BS主图_源码


   JJ:=(CLOSE+HIGH+LOW)/3;

    E:=EMA(JJ,5);

    D:=REF(E,1);

    AA1:=AMOUNT/V;

    BB1:=L<AA1*0.9;

    CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

    DD1:=L<MA(C,5)*0.921;

    EE1:=V<MA(V,5)*1.5;

    FF1:=BB1 AND CC1 AND DD1 AND EE1;

    DRAWTEXT(FF1,(LOW* 0.97),'←老鼠仓'),COLOR4080FF;

    DRAWTEXT(CROSS(REF(ZIG(3,19),1),ZIG(3,19)),HIGH*1.03,'←顶'),COLORYELLOW;

    DRAWTEXT(CROSS(ZIG(3,19),REF(ZIG(3,19),1)),LOW,'←底'),COLORYELLOW;

    猎手之路:IF(MA(C,5)>REF(MA(C,5),1),MA(C,5),DRAWNULL)COLORYELLOW,LINETHICK3;

    {预测当天最低价公式}

    A1:=REF(O,1);

    A2:=ABS((REF(C,1)-A1)/A1);

    A3:=ABS((REF(H,1)-A1)/A1);

    A4:=ABS((REF(L,1)-A1)/A1);

    B1:=ABS((A2+A3+A4)/3);

    B2:=O*B1;

    预测低一:=O-B2;

    预测高一:=O+B2;

    今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLOR4080FF,NODRAW;

    开盘价1:=OPEN;

    开盘价2:=REF(OPEN,1);

    最高价1:=HIGH;

    最高价2:=REF(HIGH,1);

    最低价1:=LOW;

    最低价2:=REF(LOW,1);

    收盘价1:=CLOSE;

    收盘价2:=REF(CLOSE,1);

    AA:=最高价2;

    BB:=最低价2;

    CC:=开盘价2;

    DD:=收盘价2;

    EE:=(AA+BB+CC+2*DD)/5;

    AAA:=EE+(AA-BB);

    BBB:=2*EE-BB;

    CCC:=2*EE-AA;

    DDD:=EE-(AA-BB);

    上升突破价:=AAA;

    上升阻力价:=BBB;

    下跌支撑价:=CCC;

    下跌反转价:=DDD;

    EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;

    心理价:=EEE;

    FFF:=(EEE+开盘价1)/2;

    GGG:=(预测低一+FFF)/2;

    预测低二:=GGG;

    {预测今日最高价公式}

    预测高二:=MA(REF(HIGH,1)/REF(CLOSE,2),27)*REF(CLOSE,1);

    DRAWTEXT_FIX(1,0.04,0.15,0,'预测低一:'),COLORYELLOW;

    DRAWNUMBER_FIX(1,0.10,0.15,0,CONST(预测低一)),COLORYELLOW;

    DRAWTEXT_FIX(1,0.15,0.15,0,'元'),COLORYELLOW,LINETHICK1;

    DRAWTEXT_FIX(1,0.04,0.20,0,'预测高一:'),COLORFFFFFF;

    DRAWNUMBER_FIX(1,0.10,0.20,0,CONST(预测高一)),COLORFFFFFF;

    DRAWTEXT_FIX(1,0.15,0.20,0,'元'),COLORFFFFFF,LINETHICK1;

    DRAWTEXT_FIX(1,0.18,0.15,0,'预测低二:'),COLORYELLOW;

    DRAWNUMBER_FIX(1,0.24,0.15,0,CONST(预测低二)),COLORYELLOW;

    DRAWTEXT_FIX(1,0.29,0.15,0,'元'),COLORYELLOW,LINETHICK1;

    DRAWTEXT_FIX(1,0.18,0.20,0,'预测高二:'),COLORFFFFFF;

    DRAWNUMBER_FIX(1,0.24,0.20,0,CONST(预测高二)),COLORFFFFFF;

    DRAWTEXT_FIX(1,0.29,0.20,0,'元'),COLORFFFFFF,LINETHICK1;

    买回价:=预测低二*1.015;

    卖出价:=买回价*(1.03);

    DRAWTEXT_FIX(1,0.04,0.10,0,'卖出价:'),COLOR8080FF,LINETHICK1;

    DRAWNUMBER_FIX(1,0.10,0.10,0,CONST(卖出价)),COLOR8080FF;

    DRAWTEXT_FIX(1,0.15,0.10,0,'元'),COLOR8080FF,LINETHICK1;

    DRAWTEXT_FIX(1,0.18,0.10,0,'买回价:'),COLOR8080FF,LINETHICK1;

    DRAWNUMBER_FIX(1,0.24,0.10,0,CONST(买回价)),COLOR8080FF;

    DRAWTEXT_FIX(1,0.29,0.10,0,'元'),COLOR8080FF,LINETHICK1;

    DRAWTEXT_FIX(1,0.01,0.02,0,'★ ======================================= ★'),COLORRED;

    DRAWTEXT_FIX(1,0.12,0.05,0,'T+0 参考操作'),COLORFFFFFF;

    DRAWTEXT_FIX(1,0.01,0.08,0,'三 '),COLOR0000FF;

    DRAWTEXT_FIX(1,0.01,0.12,0,'思'),COLOR0000FF;

    DRAWTEXT_FIX(1,0.01,0.16,0,'后'),COLOR0000FF;

    DRAWTEXT_FIX(1,0.01,0.20,0,'行'),COLOR0000FF;

    DRAWTEXT_FIX(1,0.32,0.08,0,'谨'),COLOR0000FF;

    DRAWTEXT_FIX(1,0.32,0.12,0,'慎'),COLOR0000FF;

    DRAWTEXT_FIX(1,0.32,0.16,0,'操'),COLOR0000FF;

    DRAWTEXT_FIX(1,0.32,0.20,0,'作'),COLOR0000FF;

    DRAWTEXT_FIX(1,0.01,0.24,0,'★ ======================================= ★'),COLORRED;

    总额:=AMOUNT;

    买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));

    买%:=买/AMOUNT*100;

    流入:=AMOUNT*买%/10000000000;

    流出:=AMOUNT/100000000-流入;

    净流:=(流入-流出);

    总额3:=SUM(AMOUNT,3);

    流入3:=SUM(流入,3);

    流出3:=SUM(流出,3);

    净流3:=SUM(流入-流出,3);

    总额5:=SUM(AMOUNT,5);

    流入5:=SUM(流入,5);

    流出5:=SUM(流出,5);

    净流5:=SUM(流入-流出,5);

    总额10:=SUM(AMOUNT,10);

    流入10:=SUM(流入,10);

    流出10:=SUM(流出,10);

    净流10:=SUM(流入-流出,10);

    画:=CONST(FINDHIGH(总额10,0,190,1));

    换手率1:=VOL/CAPITAL*100;

    换手率3:=SUM(VOL/CAPITAL*100,3);

    换手率5:=SUM(VOL/CAPITAL*100,5);

    换手率10:=SUM(VOL/CAPITAL*100,10);

    DRAWTEXT_FIX(1,0.71,0.10,0,'净流(亿):'),COLOR8080FF,COLORWHITE;

    DRAWTEXT_FIX(1,0.71,0.15,0,'换手率(%):'),COLOR8080FF,COLORWHITE;

    DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLOR8080FF,COLORWHITE;

    DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLOR8080FF,COLORWHITE;

    DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLOR8080FF,COLORWHITE;

    DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLOR8080FF,COLORWHITE;

    DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;

    DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;

    DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;

    DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;

    DRAWNUMBER_FIX(1,0.78,0.15,0,CONST((换手率1))),COLORYELLOW;

    DRAWNUMBER_FIX(1,0.83,0.15,0,CONST((换手率3))),COLORYELLOW;

    DRAWNUMBER_FIX(1,0.88,0.15,0,CONST((换手率5))),COLORYELLOW;

    DRAWNUMBER_FIX(1,0.93,0.15,0,CONST((换手率10))),COLORYELLOW;

    JB1:=REF(C,2)/REF(C,3)>1.095 AND REF(C,2)=REF(H,2) AND REF(C,2)/REF(O,2)>1.03;

    JB2:=REF(C,1)/REF(C,2)<0.96 AND REF(C,1)>REF(O,2);

    JB3:=C/REF(C,1)>1.05 AND O<REF(C,1);

    JBX:=JB1 AND JB2 AND JB3;

    DRAWTEXT(JBX,(LOW* 0.97),'←牛启动'),COLORYELLOW;

    {MACD}

    MA5:MA(C,5),COLORFFFFFF;

    MAPJ:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORFFFF00;

    {短线}

    V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

    V2:=(1-7/100)*(DMA(CLOSE,V1));

    V3:=(1+7/100)*(DMA(CLOSE,V1));

    V5:=MA((LOW+HIGH+CLOSE)/3,5);

    支撑:REFDATE(V2,DATE),DOTLINE,LINETHICK1,COLORLIRED;

    阻力:REFDATE(V3,DATE),DOTLINE,LINETHICK1,COLORGREEN;

    DRAWTEXT(ISLASTBAR,阻力,'阻力'),COLORGREEN;

    DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLORLIRED;

    顶点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORYELLOW,DOTLINE;

    低点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,DOTLINE;

    DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORYELLOW;

    DRAWTEXT(ISLASTBAR,低点,'底点'),COLORMAGENTA;

    {短线}

    VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));

    VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));

    VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

    VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

    VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);

    VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);

    DRAWICON(VAR1A,H,2);

    DRAWICON(VAR19,L,1);

    LOWER:MA(CLOSE,20)-1.2*STD(CLOSE,20),COLORRED,LINETHICK2;


通达信公式_简单BS主图_源码

 

关于本站 | 法律声明 | 广告合作 | RSS订阅

备案号 琼ICP备13000527号-1 同花顺公式 | 通达信公式 | 通达信指标公式

jiachenglong.cn .All Rights Reserved 联系QQ:3309881897.