通达信公式网 通达信公式网收录通达信公式、大智慧公式、飞狐公式等.域名jiachenglong.cn(谐音"假成龙")

loadding...

通达信公式_箱体压力支撑线主图_源码

发布时间: 2016-12-20 23:39

    通达信公式_箱体压力支撑线主图_源码


   MA5:MA(C,5);

    MA10:MA(C,10);

    MA30:MA(C,30);

    NN:=2;

    A1:=REF(HIGH,3)=HHV(HIGH,2*3+1);

    B1:=FILTER(A1,3);

    C1:=BACKSET(B1,3+1);

    D1:=FILTER(C1,3);

    A2:=REF(LOW,3)=LLV(LOW,2*3+1);

    B2:=FILTER(A2,3);

    C2:=BACKSET(B2,3+1);

    D2:=FILTER(C2,3);

    E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;

    E2:=(HIGH+LOW)/2;

    H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS OR BARSCOUNT(CLOSE)=1;

    L1:=(D2 AND NOT(D1 AND E1=E2));

    X1:=REF(BARSLAST(H1),1)+1;

    F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));

    G1:=F1>REF(F1,1);

    I1:=BACKSET(G1,2);

    LD:=I1>REF(I1,1);

    L2:=LD OR BARSTATUS OR BARSCOUNT(CLOSE)=1;

    X2:=REF(BARSLAST(L2),1)+1;

    F2:=BACKSET(L2 AND COUNT(H1,X2)>0,HHVBARS(IF(H1,HIGH,0),X2));

    G2:=F2>REF(F2,1);

    I2:=BACKSET(G2,2);

    HD:=I2>REF(I2,1);

    UU:=BACKSET(BARSTATUS,BARSLAST(LD)+1);

    VV:=UU>REF(UU,1);

    WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);

    XX:=WW>REF(WW,1);

    UU2:=BACKSET(BARSTATUS,BARSLAST(HD)+1);

    VV2:=UU2>REF(UU2,1);

    WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);

    XX2:=WW2>REF(WW2,1);

    前一低支撑:REF(L,BARSLAST(VV)),LINETHICK1,DOTLINE;

    箱体下沿:REF(L,BARSLAST(XX)),COLORFFFF00,;

    前一高压力:REF(H,BARSLAST(VV2)),COLOR99FF66,LINETHICK1,DOTLINE;

    箱体上沿:REF(H,BARSLAST(XX2)),COLOR00FFFF;


通达信公式_箱体压力支撑线主图_源码

 

关于本站 | 法律声明 | 广告合作 | RSS订阅

备案号 琼ICP备13000527号-1 同花顺公式 | 通达信公式 | 通达信指标公式

jiachenglong.cn .All Rights Reserved 联系QQ:3309881897.