通达信公式网 通达信公式网收录通达信公式、大智慧公式、飞狐公式等.域名jiachenglong.cn(谐音"假成龙")

loadding...

通达信公式_综合趋势波段主图_源码

发布时间: 2016-12-20 23:47

    通达信公式_综合趋势波段主图_源码


   N:=3;

    M:=7;

    N1:=20;

    N2:=11;

    Q:=132;

    NQ:=200;

    A4:EMA(C,N) COLORRED LINETHICK2;

    A7:EMA(C,M) COLORYELLOW LINETHICK2;

    A12:EMA(C,N2);

    A30:EMA(C,28);

    A20:EMA(C,N1);

    UA:=(H+C+O)/3*(A4/A7);

    H1:=(XMA(H,4)-XMA(L,4))+XMA(H,4)COLORRED DOTLINE;

    L1:=XMA(L,4)-(XMA(H,4)-XMA(L,4)) COLORGREEN DOTLINE;

    H2:=(XMA(H,7)-XMA(L,7))+XMA(H,7)COLORRED DOTLINE;

    L2:=XMA(L,7)-(XMA(H,7)-XMA(L,7)) COLORGREEN DOTLINE;

    H3:=(XMA(H,13)-XMA(L,13))+XMA(H,13)COLORRED DOTLINE;

    L3:=XMA(L,13)-(XMA(H,13)-XMA(L,13)) COLORGREEN DOTLINE;

    H4:=(XMA(H,2)-XMA(L,2))+XMA(H,2)COLORRED DOTLINE;

    L4:=XMA(L,2)-(XMA(H,2)-XMA(L,2)) COLORGREEN DOTLINE;

    HH11:(H1+H2+H3)/3 COLORRED DOTLINE;

    LL11:(L1+L2+L3)/3 COLORGREEN DOTLINE;

    DRAWTEXT(A4>0 AND ISLASTBAR,LL11 ,' 波底');

    DRAWTEXT(A4>0 AND ISLASTBAR,HH11 ,' 波顶');

    GG:=A4+0.005;

    箱顶:=MA(REF(HHV(C,30),1),2);

    买线:=EMA(C,2);卖线:=EMA(SLOPE(C,21)*20+C,42);

    DRAWTEXT(CROSS(买线,卖线)AND

    箱顶>=REF(箱顶,1),LOW-0.01,'★跟'),COLOR00FFFF;

    最低:=TROUGHBARS(L,10,1);{调整之字幅度找到低位起点}

    低价:=REF(L,BARSLAST(最低=0));

    低价_:DRAWLINE(最低=0,L,ISLASTBAR,低价,0),COLORFFFF00;

    FU:=C-低价_;

    幅度:=FU/低价_*100,NODRAW;

    转强:=100*(C-REF(C,12))/REF(C,12);

    超强:=((H+L+C)/3-MA((H+L+C)/3,88))/(0.015*AVEDEV((H+L+C)/3,88));

    通道:=1.07*DMA(C,ABS((2*C+H+L)/4-MA(C,26))/MA(C,26));

    趋势:=MA(ATAN(通道-REF(通道,1)),3);

    QS1:=IF((C>O OR C<O) AND H>=REF(C,1),ATAN(MA(H,5)*1.02-REF(MA(C,5)*1.02,1)),0);

    QS2:=IF((C>O OR C<O) AND H<REF(C,1),-ATAN(REF(MA(C,5)*1.02,1)-MA(H,5)*1.02),0);

    分界:=MA(REF((QS1+QS2),1),26);

    强势:=趋势>分界 AND 趋势>REF(趋势,1) ;

    天量:=V>REF(HHV(V,BARSLAST(BARSCOUNT(C)=1)+1),1) ;

    超级牛股:=强势 AND 超强>200 AND 转强>20 AND C>REF(C,1) ;

    DRAWTEXT(超级牛股,L*0.95,'超牛'),COLORRED,LINETHICK2;

    A1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));

    A2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1);

    金线王:EMA(A2,NQ)*1.118,LINETHICK2,COLORYELLOW;

    金线王2:EMA(A2,NQ)*1.118,LINETHICK1,COLORRED;

    买:=EMA(C,4) LINETHICK3;

    卖:=EMA(SLOPE(C,20)*10+C,35) LINETHICK3;

    DRAWTEXT(CROSS(卖,买),HIGH*1.02,'卖'),COLORGREEN;

    A71:=C-REF(C,1);

    A8:=100*EMA(EMA(A71,6),6)/EMA(EMA(ABS(A71),6),6);

    买1:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));

    DRAWTEXT(FILTER(买1=1,5),LOW,'↖买进'),COLORYELLOW;


通达信公式_综合趋势波段主图_源码

 

关于本站 | 法律声明 | 广告合作 | RSS订阅

备案号 琼ICP备13000527号-1 同花顺公式 | 通达信公式 | 通达信指标公式

Copyright © 湖南携景网络技术有限公司 jiachenglong.cn .All Rights Reserved .